SECURITYHIGHCVE-2026-66269

CVE-2026-66269: Dell OpenManage Server Administrator Unsafe Reflection Flaw

Dell patches an unauthenticated unsafe-reflection flaw in OpenManage Server Administrator that lets remote attackers bypass protection mechanisms.

Dylan H.

Security Team

September 18, 2026
3 min read
CVE-2026-66269: Dell OpenManage Server Administrator Unsafe Reflection Flaw

Affected Products

  • Dell OpenManage Server Administrator (OMSA) — versions prior to 11.1.0.3
  • OMSA Managed Node (Patch) for Windows
  • OMSA Managed Node for RHEL 8.10
  • OMSA Managed Node for RHEL 9.4

Overview

Dell has disclosed CVE-2026-66269, a high-severity vulnerability in OpenManage Server Administrator (OMSA), the systems-management agent widely deployed on Dell PowerEdge servers for hardware monitoring and remote administration. The flaw is classified as CWE-470: Use of Externally-Controlled Input to Select Classes or Code ("Unsafe Reflection"), and Dell says an unauthenticated attacker with network access could exploit it to bypass a protection mechanism in the product.

The vulnerability affects all OMSA builds prior to version 11.1.0.3, including the Managed Node (Patch) release for Windows and the Managed Node packages for RHEL 8.10 and RHEL 9.4.


Technical Details

FieldValue
CVE IDCVE-2026-66269
SeverityHigh
CVSS 3.1 Score7.3
CVSS VectorAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CWECWE-470 (Unsafe Reflection)
Attack VectorNetwork
AuthenticationNone Required
Reserved2026-07-24
Published2026-09-17

Unsafe reflection bugs occur when an application accepts externally-supplied input and uses it to dynamically select which class or code path to instantiate or execute, without adequately validating that input first. In OMSA's case, Dell's advisory frames the impact as a protection mechanism bypass — meaning the flaw can be used to sidestep a security control the product relies on, potentially opening the door to further exploitation depending on what else is reachable on the host.

Because the CVSS vector requires no privileges and no user interaction (PR:N/UI:N), any attacker who can reach the OMSA network listener can attempt exploitation without needing valid credentials.


Dell's bulletin (DSA-2026-403) bundles this issue with two related OMSA flaws disclosed the same day:

  • CVE-2026-56793 — Improper Authentication
  • CVE-2026-56794 — Path Traversal

Both affect OMSA versions prior to 11.1.0.2/11.1.0.3, suggesting a broader review of OMSA's network-facing authentication and access-control paths prompted this coordinated disclosure.


Remediation

Dell recommends all administrators running affected OMSA deployments upgrade to version 11.1.0.3 or later as soon as possible. Organizations that cannot patch immediately should:

  • Restrict network access to the OMSA management interface to trusted management VLANs or jump hosts only
  • Avoid exposing OMSA's listener directly to the internet
  • Review Dell's advisory DSA-2026-403 for the full list of affected builds and platform-specific update packages

There is no public evidence of active exploitation at the time of writing, but given the low complexity and lack of authentication required, organizations running PowerEdge fleets should prioritize patching.

Sources